大智慧公式指标-清醒买卖指标公式

Var1:=BARSCOUNT(CLOSE);
Var2:=HHV(HIGH,200);
Var3:=LLV(LOW,200);
Var4:=(Var2-Var3)/40;
Var5:=HIGH+Var4;
STICKLINE(Var1/30=FLOOR(Var1/30),Var5,Var5+3*Var4,8,0);
STICKLINE(Var1/30=FLOOR(Var1/30),Var5,Var5+2*Var4,7,0);
Var7:=REF(CLOSE-OPEN,2);
Var8:=REF(CLOSE,1);
Var9:=REF(CLOSE,2);
VarA:=REF(CLOSE,3);
VarB:=REF(CLOSE,4);
VarC:=MAX(MAX(MAX(CLOSE,Var8),Var9),VarA);
VarD:=MIN(MIN(MIN(CLOSE,Var8),Var9),VarA);
红色持股: STICKLINE(CLOSE=VarC AND (Var8>=Var9 OR Var8>=VarA) OR Var8=VarC AND (Var9=VarD OR VarA=VarD) AND CLOSE>=Var9 OR Var9=VarC AND VarA=VarD AND CLOSE>=Var8 OR VarA=VarC AND CLOSE>=Var8 AND CLOSE>=Var9,Var8,CLOSE,5,1);
品红变盘: STICKLINE(CLOSE=VarC AND Var8=VarD,Var9,CLOSE,5,1);
DRAWTEXTABS(5,5,' '),linethick1,COLOR00EEff;
黄色下跌: STICKLINE(CLOSE=VarD AND (Var8<Var9 OR Var8<VarA) OR Var8=VarD AND (Var9=VarC OR VarA=VarC) AND CLOSE<Var9 OR Var9=VarD AND VarA=VarC AND CLOSE<Var8 OR VarA=VarD AND CLOSE<Var8 AND CLOSE<Var9,Var8,CLOSE,5,0);
绿色买: STICKLINE(Var8=VarC AND CLOSE=VarD,Var9,CLOSE,5,0);
STICKLINE(Var8=VarD AND CLOSE>=Var9 OR (Var9=VarD AND Var8<=VarA OR VarA=VarD AND Var8<=Var9) AND Var9<VarB AND CLOSE>=Var8,Var8,Var9,5,0);
兰色抛售: STICKLINE(Var8=VarC AND CLOSE<Var9 OR (Var9=VarC AND Var8>VarA OR VarA=VarC AND Var8>Var9) AND Var9>=VarB AND CLOSE<Var8,Var8,Var9,5,1);
VarE:=SAR(5,1,5);
VarF:=EMA(CLOSE,30);
Var10:=IF(CLOSE>450,8,IF(CLOSE>=20 AND CLOSE<150,0.2,IF(CLOSE<20 AND CLOSE>=10,0.07,IF(CLOSE<10,0.03,0.07))));
变色龙: STICKLINE(CLOSE>VarE,VarF,VarF+Var10,6,0);
STICKLINE(CLOSE<VarE,VarF,VarF-Var10,6,0);
STICKLINE(CROSS(CLOSE,VarE),VarF,VarF-Var10,6,0);
STICKLINE(CROSS(VarE,CLOSE),VarF,VarF+Var10,6,0);
STICKLINE(RANGE(DAY,6,9) OR RANGE(DAY,27,30),VarF+0.01,VarF-0.01,6,0);
生命线: FORCAST(CLOSE,30), CIRCLEDOT;
支撑: MA(CLOSE,13)*0.955;

标签: